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License Agreement
Your use of this software indicates your acceptance of 
this license agreement and warranty. Please carefully 
read these terms and conditions prior to the use of 
this software.

Copyright
All title and copyrights in and to this software are 
owned by KORG Italy SpA (hereafter simply indicated 
as "KORG"). This software is protected by copyright 
laws and international treaty provisions.

Freeware
Although this software is free, it is not "public do-
main". It is a copyrighted software program, and KORG 
reserves all rights. Therefore:
• This software cannot be sold, either by itself or in 
combination with any other product, without the ex-
press written permission of KORG.
• If you are a user group which is publishing a CD-ROM 
or floppy collection, you may include this software and 
all of its related files without restriction, save that the 
entire original package is included.
• If you are a hard disk vendor which distributes PD, 
shareware, and freeware on your disk drives, you are 
welcome to distribute this software. Contact KORG for 
up-to date versions and information.
• Commercial publishers and distributors of CD-ROM 
software collections, to include any and all software 
compilations provided as an adjunct to printed or on-
line publications, may not distribute this software on 
CD- ROM without the express written permission of 
KORG.
• This software may be posted on an information ser-
vice which charges its users for general connection 
time and downloading, but it may NOT be posted to an 
information service which will charge for the specific 
right to download it, without the express written per-
mission of KORG.
• This software may be given away as a support utility 
for a package which is itself to be given away. People 
who need to distribute it as a support utility should 
contact KORG for up-to-date versions and information.
Please address all correspondence to: 
	 KORG Italy SpA
	 Via Cagiata, 85
	 60027 Osimo (AN) - Italy
	 www.KORG.com
Please note that we cannot provide technical support 
for this software (or any of our other freeware prod-
ucts).

Disclaimer of Warranty
THIS SOFTWARE AND THE ACCOMPANYING FILES 
ARE DISTRIBUTED "AS IS" AND WITHOUT WARRAN-
TIES AS TO PERFORMANCE OR MERCHANTABILITY 
OR ANY OTHER WARRANTIES WHETHER EXPRESSED 
OR IMPLIED. NO WARRANTY OF FITNESS FOR A PAR-
TICULAR PURPOSE IS OFFERED.

Distribution
This software is freeware and may be freely copied 
and distributed as long as the entire unmodified pro-
gram is copied and no fee is charged.

Support
This software is given "as is". No support is granted 
by KORG.

Liability
KORG shall not be liable for errors contained in infor-
mation and software downloaded from the KORG Web-
site, or otherwise obtained from the KORG Website 
in any manner. KORG will not in any event be liable 
for any direct, indirect, special, incidental or conse-
quential damages whatsoever (including lost profits, 
lost data, or business interruption) related to any use, 
reproduction, modification, or distribution of the soft-
ware, results, documentation or links provided by the 
KORG Website.

No Disassembly or Decryption
You may not disassemble or decompile the Software 
without prior written consent of KORG.

Transfer
Your license will automatically terminate upon any 
transfer of the Software. Upon transfer, you must de-
liver the Software, including any copies and related 
documentation, to the transferee. The transferee 
must accept these License Terms as a condition to the 
transfer.

Termination
KORG may terminate your license upon notice for 
failure to comply with any of these License Terms. 
Upon termination, you must immediately destroy the 
Software, together with all copies, adaptations and 
merged portions in any form.

Data Handling
Data may sometimes be lost due to incorrect user ac-
tion. Be sure to backup important data. KORG will not 
be responsible for damages caused by data loss.

Disclaimer
The information contained in this manual have been 
carefully revised and checked through. Due to our 
constant efforts to improve our products, the speci-
fications might differ to those in the manual. KORG 
is not responsible for any eventual differences found 
between the specifications and the contents of the in-
struction manual – the specifications being subject to 
change without prior notice.

Trademarks
Windows is a registered trademark of Microsoft Corpo-
ration. All other trademarks or registered trademarks 
are the property of their respective holders.

http://www.korg.com
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Introduction
Thank you very much for using KORG’s SongBook Editor for the Pa-Series 
Professional Arrangers! With SongBook Editor you can:

•	 Create new SB (SongBook) Entries.

•	 Import multiple MID/KAR and MP3 files and batch-convert them to SB Entries.

•	 Edit most SB Entry parameters in multiple entries at once.

•	 Rename SB Entries and edit parameters faster, by using the PC’s keyboard.

•	 Add Lyrics as TXT files linked to the SB Entries.

•	 See all parameters in adjacent columns, and quickly sort the SB Entries in the 
Book list.

•	 Create and edit Set Lists, using multiple selection and drag&drop.

•	 Drag&drop SB Entries between SongBooks, and between SongBooks and text 
documents or spreadsheets.

•	 Change the file path of Direct Styles, MID/KAR, MP3 files and TXT files.

•	 Change reference to Style locations and banks.

•	 Batch-remap all references to the Styles and Pads.

•	 Copy Keyboard Sets between SB Entries.

•	 Export a list of songs as a text file, to print your playlist for a show.
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Installing the software

PC system requirements

To use SongBook Editor, you need a PC running under Microsoft® Windows® 
7/8/8.1/10™.

KORG instrument requirements

SongBook Editor v3.0 supports Pa4X, Pa1000 and Pa700. For older models, 
please use SongBook Editor v2.0. The following tables show the requirements to 
use SongBook Editor with your KORG instrument.

•	 These models require SongBook Editor v3.0 (or newer):

Model OS

Pa4X latest version

Pa1000 latest version

Pa700 latest version

•	 These models require SongBook Editor v2.0:

Model OS

Pa4X up to v1.2.4

Pa3X latest version

Pa3XLe latest version

Pa2X latest version

Pa1X latest version

Pa900 latest version

Pa800 latest version

Pa600 latest version

Pa500/Pa588 latest version

Pa300 latest version

HAVIAN 30 latest version

Note: You can find the latest OS in our web site (www.korg.com).

http://www.korg.com
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Installing the software

After downloading the installer, follow these easy steps:

1	 Double-click the installer’s icon.

2	 Follow the instructions appearing on screen.

Getting help

Whenever you need to access these instructions, choose the Help > SongBook 
Editor User Guide (F1) command from the application menu.

SongBook and removable media

SongBook Editor can read resources (Direct Styles, MID/KAR, MP3, TXT files) 
from storage devices connected to the PC’s USB ports. You can therefore work 
with files on a storage device connected to your PC’s USB ports. After editing, 
you can reconnect the device to the instrument’s USB HOST port.

Keeping all the resources on a removable media is recommended, since it allows 
for an easier management of all data linked to the SongBook.
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Glossary
What is a SongBook?

The SongBook is the onboard music database of your KORG Pa-Series instru-
ment, allowing you to organize and quickly retrieve the Songs you created start-
ing from Styles, MID/KAR or MP3 files.

What is a SB Entry?

A SB (SongBook) Entry is an entry of the onboard database, that, in addition to 
a link to the Style or Song, may include information like the artist, title, genre, 
number, key, tempo, and meter (time signature) of a specified song. SB Entries 
also include the Sounds you play on the keyboard.

What is a SongBook’s Song?

Songs, in the SongBook, are the equivalent of SB Entries. You may call them with 
the more jargon-driven term ‘SB Entry’, or the more musician-inspired ‘Song’.

What are Styles, MIDI Songs and MP3 Songs?

Each SB Entry (or ‘SongBook’s Song’) is linked to a Style, MIDI Song or MP3 Song. 
A Style is a set of cycling patterns following you when you play chords on the 
keyboard. A MIDI Song is a .mid or .kar file, playing the internal sounds. An MP3 
Song is an .mp3 file, playing recorded audio. Together, in the SongBook, they 
form an alliance to play songs with all the needed sounds and effects.

What are User, Local and Direct?

User data are the ones you create or load from an external storage device to 
the internal memory. Local data are those added with an Add-On. Direct data 
are those residing on an external storage device, and selected as the Direct SET.

On the instrument, you can see at the same time entries from the User, Local  
and Direct SongBooks. With SongBook Editor, you only see the entries of the 
SongBook you have loaded as a SET folder.
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Creating the SongBook on 
the instrument
Before editing your SongBook with SongBook Editor, there are some operations 
you should carry on on your instrument to create the original SongBook on 
which to work.

Creating the Style-based SB Entries

It is advisable to create Style-based entries on the instrument, since this will al-
low all the actual values of the Style Settings (including Sounds, EQ, FX, Keyboard 
Sets, Pads, etc…) to be copied to the SB Entries. On the contrary, creating Style-
based entries with SongBook Editor would only assign them default values, and 
would therefore require some additional work after reloading the SongBook.

1	 On the instrument, create a new SongBook database, or edit an existing one. 
Please read the instrument’s User Manual for the relevant instructions.

2	 Still on the instrument, create all Style-based SB Entries, as described in the 
User Manual.

Creating the MID/KAR- and MP3 file-based SB 
Entries

If you want, create the MID/KAR- and MP3-based entries on the instrument. 
However, please keep in mind that it is easier and quicker to create them directly 
in SongBook Editor.



6

Saving the SongBook and the 
linked data
Before editing the SongBook database with SongBook Editor, you must save it, 
together with all the linked data.

Preparing the external storage device

1	 Connect an USB storage device to (one of) the USB HOST port(s) of the Pa-
Series instrument.

You can use anything you like: an external hard disk drive, an SSD drive, an USB 
pendrive. Be sure there is enough room to contain all your data (the SongBook 
and the linked files).

2	 Go to the Media > Format page, and format the external storage device. Please 
refer to the User Manual for information on the Format procedure.

Warning: Formatting will delete any data on the external storage device.

Saving the SongBook and Styles

From the Pa-Series instrument, save the SongBook and all the associated Styles. 
This will allow SongBook Editor to know the names of the Styles.

Saving the User Styles

When User Styles are loaded with the SongBook, SongBook Editor can know 
their name and position.

Saving the Custom Factory Styles

Standard Factory Style names are always shown in SongBook Editor. You don’t 
need to save anything else, in addition to the SongBook, to let SongBook Editor 
know their names.

If you customized the Factory Style banks, you have to save them, to let SongBook 
Editor learn their names. To save them, remove the Factory data protection.
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Saving the the Local Styles

The name of the Local Styles supplied by KORG (for example, with the Oriental 
or Musikant versions) are always shown in SongBook Editor. You don’t need to 
save anything else, in addition to the SongBook, to let SongBook Editor know 
their names.

If you customized the Local Styles supplied by KORG, you have to save them, 
to let SongBook Editor learn their names. They behave exactly as the Custom 
Factory Styles. To save them, remove the Factory data protection.

Also, the name of the Local Styles supplied as Add-Ons by other developers 
are not automatically shown in SongBook Editor. You have to save them, after 
removing the Factory data protection.

Removing protection from the Factory and Local Styles

1	 On the instrument, go to the Global > Mode Preferences > Media page.

2	 Deselect the Factory Protect checkbox, to remove the write and save protection 
from the Factory Styles.

Saving the SongBook and Styles

1	 Still on the instrument, go to the Media > Save page, and select the ALL folder 
to save all.

2	 Touch the Save button, and use the Device pop-up menu to choose the external 
USB storage device as the target of the Save All operation.

3	 Create a New SET folder in the external storage device.

The new SET folder will contain the Book (SBD) and Set List (SBL) files. It will also 
contain all the User/Favorite (and Custom Factory/Local) Styles.

Collecting the MID/KAR, MP3 and TXT files

You can collect all the needed files into the external USB storage device in which 
you save the SongBook files. All your data will easy to be moved between the 
instrument and a PC.

1	 Still on the instrument, go to the Media > Copy page, and copy all the Direct Style 
and Pad, MID/KAR, MP3 and TXT files needed by the SongBook. Copy them from 
all the folders inside the instrument’s internal memory or storage devices to the 
external USB storage device.
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Collecting the different types of songs in separate folders (for example, by name, 
music genre or type of file) will make retrieving them later easier.

Important: Do not copy files inside any SET folders! These folders are reserved to the 
instrument’s internal data, and must be left untouched. Use generic folders instead.

2	 Remove the external USB storage device from the instrument, and connect it to 
your PC. If you like, copy into it any other MID/KAR, MP3 and TXT file that you 
plan to use with the SongBook. You can also copy any additional Direct Styles 
and Pad to the same device.

Working in the internal memory or drives

If you prefer, you can save the SongBook and associated data inside the internal 
memory, or an internal drive (if any), of your Pa-Series instrument. However, 
since using an external USB storage device makes moving the files between the 
instrument and a PC easier, we don’t recommend it.

To make the PC see the internal storage devices of your instrument, you must 
connect the instrument to a PC by using an USB cable. When connected to a Pa-
Series instrument, the PC can see the instrument’s internal memory and drives 
as if they were ordinary storage devices. At this point, you can directly work with 
the SongBook files, and the MID/KAR, MP3 and TXT files contained inside the 
instrument.

1	 Use a standard USB cable to connect the USB DEVICE port of the instrument to 
an USB port of the PC.

2	 On the instrument, go to the Media > USB page. Use the Device pop-up menu to 
choose the KORG DISK device (that is, the internal memory), or any other inter-
nal storage device where you saved the SongBook files. Then press the Enable 
button. The icon of the instrument’s internal memory will appear as a storage 
device connected to your PC.

3	 If you moved the linked resources (MID/KAR, MP3, TXT files) to an external stor-
age device (used as an external portable library), connect it to a different USB 
port on your PC.
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Making a backup

For safety reasons, before starting to edit the SongBook we suggest to make a 
backup of the instrument’s memory content.

1	 You can make a backup into one of the internal storages of the instrument. 
However, if you want to use an external USB storage device, connect it to (one 
of) the USB HOST port(s) of the Pa-Series instrument. If needed, format it.

2	 Go to the Media > Utility page, and use the Full Resources Backup command to 
backup the data.

Important: Always keep a backup copy of your original SongBook files before editing 
them! Saving an edited SongBook file over an existing one will permanently delete the 
older one.

From here on – do not edit anything on the 
instrument!

Starting from the following pages, all editing will be done on a PC and not on 
your instrument. Any further editing, carried on on the instrument before re-
loading the modified SongBook files, will be lost.
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Launching SongBook Editor 
and choosing the Target

Launching SongBook Editor

After having connected the external USB storage device or the instrument to 
the PC, run SongBook Editor. The main screen of the software will appear, with a 
standard menu and a single window split in three panels, as shown in the illustra-
tion below. (When first running the application, the panels are empty; we show 
them populated for ease of understanding).

The Set Lists panel. This is where you can see all the 
available Set Lists associated to the selected Book. 
This panel is the equivalent of the Set List pop-up 

menu of the instrument.

The Selected List panel. This is were 
you can see the content of the selected 
Set List. It is the equivalent of the Set 

List page of the instrument.

The Book panel. This is where the full list of 
Songs included in the SongBook appears. It is the 

equivalent of the Book page of the instrument.
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Choosing the Target

The first time you run SongBook Editor, use the Target parameter in the 
Preferences dialog to select your instrument as the “target” device. This will 
allow the software to use the correct file format for your instrument. You won’t 
have to select it again later, since this setting will remain memorized through all 
the subsequent editing sessions.

1	 Choose the File > Preferences… command to open the Preferences dialog. You 
will see the Target parameter on top of the dialog.

2	 Click the Change… button to open the Target dialog.

 

The available targets are the ones listed in the following table.

Model Version Target

Pa4X Standard Pa4X STD

Oriental Pa4X ORT

Musikant Pa4X MUS

Pa1000 Standard Pa1000

Pa700 Standard Pa700 STD

Oriental Pa700 ORT

3	 Choose from the list the target corresponding to your instrument, then click the 
OK button to confirm.

4	 Click the OK button to close the Preferences dialog.
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When done, the chosen target will be shown in the top-right corner of the ap-
plication window.
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Opening the SongBook with 
SongBook Editor
The SongBook can be opened with SongBook Editor, where you can see its con-
tent in a database-like fashion.

Opening the SongBook
Before editing, open the SongBook files from the USB storage device (or the 
internal memory, or an internal storage, of the instrument).

1	 In SongBook Editor, choose the File > Open command, and browse the files.

2	 Find the SET folder containing the SongBook files (the ones you previously 
saved), and click its name to highlight it.

3	 Click the Select Folder button to load the SET folder.

Browsing the SB Entries in the Book panel
After having opened the SongBook, the list of SB Entries it contains will appear in 
the Book panel (corresponding to the Book page on the instrument). The Book’s 
content is shown in a database-like fashion, with each SB Entry corresponding to 
a row, and the various parameters of the entry shown in the adjacent columns.



14

Customizing the list view

Showing/hiding columns

You can choose which columns to see in the panels.

1	 Click a column header with the right mouse button.

2	 When the list of available options appears, select/deselect the name of the col-
umn to be shown/hidden.

Resizing columns

You can change the width of each column to better fit the content.

1	 When moving the mouse pointer over the line dividing two column headers, the 
pointer’s shape changes to the resize tool. Grab the right margin of a column 
header, then drag it.

2	 To set a column’s width to the optimum size, double-click its right margin.
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Changing the sorting order

You can change the order of the SB Entries shown in the list, by choosing a par-
ticular sorting criterion (by Name, Genre, Author, and so on).

1	 Click a column header to select the corresponding sorting criterion.

2	 Click a second column header to change the sorting.

Each time you choose a different sorting criterion, the previous criterion is con-
sidered as a “sub-criterion” for the new one. For example, you can alphabetically 
reorder your entries by Name:

Then you change the order to Genre; inside the genre alphabetical ordering, 
entries are still alphabetically ordered by name:

3	 Click the selected column header to change the sorting order from ascending to 
descending, or vice versa.
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Changing the fonts and colors

Fonts and colors of the list items can be customized.

1	 Choose the File > Preferences… command to open the Preferences dialog.

 

2	 Use the options of the Fonts & Color section to change the fonts and assign a 
different background color to the various panels. You can also assign different 
background colors to the alternating odd and even rows. Entries edited but not 
yet saved can have their own color.

3	 When done, click the OK button to close the dialog.
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Filtering the entries shown in the Book panel

If you want to view only the SB Entries based on the songs of a single author, or 
the songs of a particular genre, or selected according to other criteria, you can 
apply a ‘filter’ to the current view.

1	 To define the view criteria click the Filter… button on the lower left corner of the 
Book panel, or choose the Edit > Filter… (Ctrl+F) command to open the Filter 
dialog.

2	 Edit the various filtering criteria (the available criteria are the same as on the 
Pa). When done, click the OK button to close the dialog.

3	 Click the Filtered checkbox in the lower left corner of the Book panel to make 
the checkmark appear. The entries shown in the Book panel will change.

4	 When you want to see all the entries again, remove the checkmark from the 
Filtered checkbox.
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Creating a new SongBook 
with SongBook Editor
You can create a new, empty SongBook, where you can manually add new en-
tries or import MID/KAR and MP3 files to automatically create new entries.

•	 To create a new SongBook, choose the File > New command from the menu.
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Creating new SB Entries
You can create new entries, to be added to a new or existing SongBook.

Creating a new SB Entry

You can create three different types of SB Entry.

1	 Use the Edit > New Entry commands to create new SB Entries with SongBook 
Editor. 

•	 Choose the Edit > New Entry > Style (Ctrl+N) command to create a Style-based 
entry. As an alternative, right-click and choose the New Entry > Style command.

•	 Choose the Edit > New Entry > MIDI (Ctrl+Shift+N) command to create a MID/
KAR-based entry. As an alternative, right-click and choose the New Entry > MIDI 
command.

•	 Choose the Edit > New Entry > MP3 (Alt+N) command to create an MP3-based 
entry. As an alternative, right-click and choose the New Entry > MP3 command.

2	 Edit the various parameters in the Edit dialog (see “Editing the SB Entries” on 
page 27).
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Linking or adding resources

When you create or edit a SB Entry, you can link some of the resources contained 
in your instrument’s Factory/Local/User banks. You can also link some of the 
resources from an USB storage device, as described below.

Resource Type Position

Style Factory/Local/User banks. Direct Styles also on internal memory, 
internal HDD, SD, USB storage device

Voice or Guitar Preset Factory/Local/User banks

MID/KAR file Internal memory, internal HDD, SD, USB storage device

MP3 file Internal memory, internal HDD, SD, USB storage device

TXT file Internal memory, internal HDD, SD, USB storage device

Other resources are included in the various entries of the SongBook itself:

Resource Type Position

Keyboard Set Other entries of the SongBook

Please keep in mind that no resource (excluding the Keyboard Sets) is copied into 
the SB Entries — they are only linked to the entries. If you move the SongBook 
files to a different instrument, or the linked resources to a different folder or 
position, links can be broken, unless you recreate the correct data structure (see 
“Frequent operations” on page 46).

If you keep all the Direct Styles, and the MID/KAR, MP3 and TXT files in the same 
external USB storage device, these data will be easy to move with the SongBook. 
However, system resources (internal Styles, Voice or Guitar Presets) will still be 
unique to a particular Pa-Series instrument.
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Importing data to SB Entries
Instead of being individually created one by one, SB Entries can be created en 
masse by importing a series of MID/KAR or MP3 files.

Importing MID/KAR and/or MP3 files

You can import all the MID/KAR and MP3 files contained in an external USB stor-
age device (or in a folder inside your instrument). These files will be automati-
cally converted into SB Entries. The imported entries can be added to an existing 
SongBook, or to a new, empty SongBook.

In case there are ID3 data inside the imported MP3 files, these will be converted 
into SongBook data (Title, Author…). Basic data and some metadata contained in-
side MID/KAR files will also be converted into SongBook data (Master Transpose, 
Key, Time Signature, Tempo…).

Preparing the data

It is advisable that all the files stay in the same place. Copy all your MID/KAR, 
MP3 and TXT files into an external USB storage device (or, if you prefer, into the 
internal memory or internal storage device of the instrument). The linked files 
will have to be accessible when using the SongBook you are editing.

1	 Connect the external USB storage device containing the SongBook to the PC. 
(If the SongBook is in the internal memory or storage device of the instrument, 
connect the instrument to the PC, and enable USB connection on the instru-
ment).

2	 Open the folders containing the data to be imported as new windows on your 
PC’s desktop.

3	 Copy all the sparse MID/KAR, MP3 and TXT files from the external devices to 
the external USB storage device containing the SongBook (or to the internal 
memory or storage device of the instrument). Collecting the different types of 
songs in separate folders (for example, by name, music genre or type of file) will 
make retrieving them later easier.

Important: Do not copy files inside any of the SET folders! These folders are reserved to 
the instrument’s internal data, and must be left untouched. Use generic folders instead.



22

Importing the files

After you have collected all the files into the external USB storage device con-
taining the SongBook (or into the instrument’s internal memory or storage de-
vices), start importing them.

1	 In SongBook Editor, choose the File > Import Files… (Ctrl+I) command. A stan-
dard file selector will appear.

2	 Select the file(s) with the .mid, .kar and .mp3 extensions you want to import. 
Then click the Open command to import the selected MID/KAR and MP3 files, 
and convert them to SB Entries.

Hint: When in this file selector, you can use the Shift+click shortcut to select multiple con-
tiguous files, or the Ctrl+click shortcut to select multiple non-contiguous files.

3	 The imported files will appear in red (by default). They will become black again, 
once the SongBook has been saved. Please note that text colors can be custom-
ized in the Preferences dialog (see “Changing the fonts and colors” on page 
16).

Editing the entries

After having imported the files, you can go on editing single or multiple entries. 
For example, you can copy the Keyboard Sets or Voice Presets from other en-
tries, choose the Author and Genre, link a text file to be used as the Lyrics, and 
so on. Please refer to the relevant instructions later in this manual.
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Editing basics
Before editing, please learn the basic editing operations. These operations affect 
the entries in all panels (Book, Set Lists, Selected List).

How to access editing

Editing parameters

•	 Double-click the entry you want to edit to open the Edit dialog (see “Editing the 
SB Entries” on page 27).

•	 As an alternative, right-click it, and choose the Edit command.

Please note that not all parameters can be edited, and not all parameters may ap-
pear for the chosen target. The following table shows which parameters can or can’t 
be edited. Please see the instrument’s User Manual for more information on their 
meaning.

Parameter Editable

Index (only in Set List entries)

Sel.No. (Song Selection Number) √

Type (Resource Type)

Name (SB Entry’s Name) √

Artist(*) √

Genre(*) √

Key(*) √

Tempo

Meter(*) √

M.Transp. (Master Transpose)

Synchro Start (Synchro Start button) √

Synchro Stop (Synchro Stop button) √

Memory (Memory button) √

Keyboard Set #1…4 √

Voice Preset √

Global Voice Preset √

Guitar Preset only on some models

Global Guitar Preset only on some models
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Parameter Editable

Resource
Style based entry: Style bank and Style name. Song based entry: File path 
(including name) of the associated MID/KAR or MP3 file

√

Direct SET
File path (including name) of the Direct Style associated to the SB Entry

√

Txt file
File path (including name) of the text file associated to the SB Entry 

√

(*) Note: As in the instrument, these parameters are just indicators. They have no effect on the 
entry’s playback.

Entries that have been edited, but not yet saved, are shown in red (by default). 
They will become black again once the SongBook has been saved. Please note 
that text colors can be customized in the Preferences dialog (see “Changing the 
fonts and colors” on page 16).

Editing multiple entries

You can select and edit more that a single entry at once. Please be advised that 
some parameters cannot be modified when editing multiple entries (for example, 
the entry’s name, or parameters pertaining to different types of entries).

1	 Click the entries to select.

•	 Select more consecutive entries by Shift-clicking.

•	 Select more non-consecutive entries by Control-clicking.

2	 Right-click the selected entries and choose the Edit command.

How to edit the parameters

Editing text strings

Some parameters – for example, SB Entry names – require you enter a text string. 
Note that names are case-sensitive, i.e., “Name” is not the same as “name”. Also, 
please note that duplicate entry names are not allowed.
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Editing numeric fields

Numeric fields – like the Song Selection Number – can either be changed step-
by-step by clicking the +/- signs next to them, or by clicking the field and directly 
entering the number.

Choosing parameters from a pop-up menu

Some parameters allow you to choose a value from a pop-up menu. Click the 
down-pointing arrow next to the option name and choose the desired value.

Automatically updated pop-up menus

Each time you create a new entry or edit an existing one, its data are added to 
the pop-up menus, so that you can choose them when entering/editing other 
entries. For example, if you enter “Rock” in the Genre field, and this genre is 
not yet included in the list, the “Rock” option will be automatically added to the 
Genre pop-up menu.

Cutting, copying and pasting the entries

You can use the standard Cut, Copy and Paste operations inside SongBook Editor, 
between different SongBook Editor instances, or between SongBook Editor and 
a text editor or spreadsheet. The clipboard’s content is in the “text delimited by 
tabs” format.

•	 Choose the Edit > Cut (Ctrl+X) command to cut the selected item(s) and move 
it (them) to the clipboard. As an alternative, right-click the item(s) and choose 
the Cut command.

•	 Choose the Edit > Copy (Ctrl+C) command to copy the selected item(s) to the 
clipboard. As an alternative, right-click the item(s) and choose the Copy com-
mand.

•	 Choose the Edit > Paste (Ctrl+V) command to paste at the current position the 
item(s) contained in the clipboard. As an alternative, right-click and choose the 
Paste command.
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Deleting entries

•	 Select the item(s) to be deleted, then choose the Edit > Delete (Del) command 
to delete. As an alternative, press the Delete key, or right-click and choose the 
Delete command.

Selecting all entries

•	 Choose the Edit > Select All (Ctrl+A) command to select all the entries.

•	 As an alternative, right-click and choose the Select All command.
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Editing the SB Entries
By opening the Edit dialog, you can edit the fine details of each new or existing 
entry.

Note: Depending on your Pa-Series instrument, the following editing dialogs could be 
slightly different than the ones shown.

Editing Style-based entries

This type of entry will automatically select the Style Play mode and select a 
Style.

•	 Choose a Style-based entry, and double-click it to open the Edit Style Entry 
dialog.

With this type of entry, you can choose (respectively) the bank and position num-
ber of the assigned Style.

Parameters

Keyboard Sets

Voice Preset 

Bank/Style

Text file 
path

Previous/
Next Entry 

buttons

Guitar Preset 
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Parameters — These are the same parameters found in the Book pages of the 
instrument. The Tempo and Master Transpose values are those saved into the 
Style Settings.

Keyboard Sets — The four Keyboard Sets contained in the SB Entry. You can edit 
their names, and copy them from a different entry by clicking the Browse icon  
( ) next to the name.

Voice Preset — Voice Preset assigned to the entry. When the Use global Voice 
Preset checkbox is selected, the global Voice Preset will be used, and you can’t 
choose a local Voice Preset.

Guitar Preset — Guitar Preset assigned to the entry (only available on Pa1000 
and Pa700). When the Use global Guitar Preset checkbox is selected, the global 
Guitar Preset will be used, and you can’t choose a local Guitar Preset.

Style Bank — Choose the Style Bank from the pop-up menu.

If you select a Direct bank, the Direct SET editable areas appear, to let you link 
the Direct Style from its SET folder. Click the Browse icon ( ) next to the path 
area to open a standard file selector, and choose the Direct Style.

Be sure to only select a single Direct SET folder for all the Direct Styles. Since the 
instrument can only see a single Direct SET folder at a time, this will allow you to 
always see the linked Styles.

Style — This is the Style inside the selected Bank; both the Style number and 
name are shown (assuming all the User or Custom Factory/Local Styles have 
been saved with the SongBook, see page 6).

Text drive unit and path — Click the Browse icon ( ) next to the path area to 
open a standard file selector, and choose the text file.

When entering a file path, the path is divided into the drive unit (on the left) and 
the actual path (on the right). This allows you to change the drive separately 
from the path, so that you can copy entire directories between drives, without 
having to re-edit long directory strings. You do not need to connect the external 
drives while editing.
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The typical path format is the following:

[label]/foldername1/foldername2/filename.txt

When editing multiple entries, you can only edit the path, but not the file name; 
this is useful if you renamed a folder, or have moved the linked files to a different 
folder or directory level. Check the Path checkbox, and enter a string similar to 
the following one (without any final slash):

[label]/newfoldername1/newfoldername2

Drive units, like hard drives and USB storage devices, are represented by their 
label, as indicated in the following table:

Label Storage device Pa4X Pa1000 Pa700

[KORG DISK]* Internal memory (SSD) √ √ √

[KORG HD]* Internal Hard Disk (where available) √

[KORG SD]* microSD (when inserted) √ √ √

[label]* Storage device connected to one of the 
USB HOST ports

√ √ √

* The [label] is the name assigned to the storage device. When manually writing the label, do not 
forget to also include the square brackets around the name (for example, “[KHD_USER]”).

Previous/Next Entry buttons — Click the Previous button to edit the previous 
entry of the list, or the Next button to edit the next entry of the list, without hav-
ing to close the dialog.

OK/Cancel buttons — Click the OK button to confirm changes and close the dia-
log, or the Cancel button to abandon the changes and close the dialog.
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Editing MID/KAR-based entries

This type of entry will automatically select the Song Play mode, and assign a 
Standard MIDI File (MID or KAR file) to the Player (or one of the Players).

•	 Choose a MID/KAR-based entry and double-click it to open the Edit MIDI Entry 
dialog.

With this type of entry, you can write the full path of the Standard MIDI File used 
as the resource.

Parameters

Keyboard Sets

Voice Preset 

MID file 
path

Text file 
path

Previous/
Next Entry 

buttons

Guitar Preset 

Parameters — These are the same parameters found in the Book Edit pages of 
the instrument. Entries created on the instrument or imported get the starting 
Tempo of the MID/KAR file. Entries created in SongBook Editor, or edited in order 
to change the referred MID/KAR file, get a default blank Tempo value (---) (not 
shown in this dialog).

Keyboard Sets — The four Keyboard Sets contained in the SB Entry. You can edit 
their names, and copy them from a different entry by clicking the Browse icon  
( ) next to the name.
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Voice Preset — Voice Preset assigned to the entry. When the Use global Voice 
Preset checkbox is selected, the global Voice Preset will be used, and you can’t 
choose a local Voice Preset.

Guitar Preset — Guitar Preset assigned to the entry (only available on Pa1000 
and Pa700). When the Use global Guitar Preset checkbox is selected, the global 
Guitar Preset will be used, and you can’t choose a local Guitar Preset.

Standard MIDI File and text paths — Click the Browse icon ( ) next to the path 
area to open a standard file selector, and choose the MID/KAR file or the text 
file. Click the Update icon ( ) to update the information contained in the MID/
KAR file (in case the file contains any) (to be used when the linked file has been 
replaced).

The MID/KAR file and text paths are divided into the drive unit (on the left) and 
the actual path (on the right). This allows you to change the drive separately 
from the path, so that you can copy entire directories between drives, without 
having to re-edit long directory strings. You do not need to connect the external 
drives while editing.

The typical path format is the following:

[label]/foldername1/foldername2/filename.mid

When editing multiple entries, you can only edit the path, but not the file name; 
this is useful if you renamed the folder, or have moved the songs to a different 
folder or directory level. Check the Path checkbox, and enter a string similar to 
the following one (without any final slash):

[label]/newfoldername1/newfoldername2

Drive units, like hard drives and USB storage devices, are represented by their 
label (see table on page 29).

Previous/Next Entry buttons — Click the Previous button to edit the previous 
entry of the list, or the Next button to edit the next entry of the list, without hav-
ing to close the dialog.

OK/Cancel buttons — Click the OK button to confirm changes and close the dia-
log, or the Cancel button to abandon the changes and close the dialog.
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Editing MP3-based entries

This type of entry will automatically select the Song Play mode, and assign an 
MP3 file to the Player (or one of the Players).

•	 Choose an MP3 file-based entry, and double-click it to open the Edit MP3 Entry 
dialog.

With this type of entry, you can write the full path of the MP3 file used as the 
resource.

Parameters

Keyboard Sets

Voice Preset 

MP3 file 
path

Text file 
path

Previous/
Next Entry 

buttons

Guitar Preset 

Parameters — These are the same parameters found in the Book Edit pages 
of the instrument. Entries based on MP3 files get a default blank Tempo value  
(---) (not shown in this dialog). The Update icon ( ) updates ID3 tags (in case the 
MP3 file contains any of them).

Editing of the various parameters is the same seen above for MID/KAR file-based 
entries.
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Copying the Keyboard Sets from other entries

While in the Edit dialogs, you can copy Keyboard Sets from other entries.

Copying a single Keyboard Set

1	 While in an Edit dialog, click the Browse icon ( ) next to the Keyboard Set’s 
name to be replaced.

2	 When the Choose source Keyboard Set dialog opens, choose an item from an-
other entry.

Copying all Keyboard Sets

1	 While in an Edit dialog, click the Copy all Keyboard Sets icon over the names of 
the Keyboard Sets to be replaced.

2	 When the Choose source Keyboard Set dialog opens, choose an entry from 
which to copy the Keyboard Sets from.
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Set Lists
Set Lists are collections of SB Entries selected from the complete Book list. You 
can use them to create your own playlists. Up to 256 Set Lists can be contained 
into each SongBook database.

Creating a new Set List

•	 Choose the Edit > New List (Ctrl+L) command to create a 
new Set List. As an alternative, right-click anywhere in the 
Set Lists panel and choose the New List command. The 
new list will appear in the Set Lists panel.

Adding entries to the selected Set 
List

1	 Select the Set List to which you want to add entries.

2	 Grab entries from the Book panel, and drag them onto the 
Selected List panel.

Hint: You can use the Shift+click shortcut to select multiple con-
tiguous entries, or the Ctrl+click shortcut to select multiple non-
contiguous entries.
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Seeing the content of a Set List

•	 Click a Set List name in the Set Lists panel to see its content in the Selected List 
panel on its right.

The Set List’s content is shown in a database-like fashion, with each entry in a 
row, and the various parameters of the entry in adjacent columns.

Contrary to the Book list, this list cannot be reordered in a different way by click-
ing the various column headers. The only possible order is the one shown in the 
list, that is the order in which the entries will be played back.

Editing entries

You can apply to the entries shown in the Selected List panel the same edit-
ing operations already discussed for the entries shown in the Book panel. See 
“Editing the SB Entries” on page 27 for more information.

Moving entries up/down

You can reorganize the entries in the Set Lists or the Selected List panel by 
moving each of them to a different position.

•	 Simply drag&drop the entries to move them up or down the list.

•	 As an alternative, select the item to be moved, then choose the Edit > Move Up 
(Ctrl+Arrow Up) or Move Down (Ctrl+Arrow Down) command.

•	 You can right-click the entry and choose the Move Up or Move Down command.
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Deleting a Set List

You can delete Set Lists you no longer need.

•	 Select the Set List to be deleted in the Set Lists panel, then press Delete.

•	 As an alternative, right-click the item to be deleted, then choose the Delete 
command.
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Remapping Style and Pads
When switching to a new instrument, or customizing the Style banks in your in-
strument, you can automatically remap the Styles and Pads assigned to the SB 
Entries. This is recommended when having to relink a large number of entries.

The remapping table

To remap Styles and/or Pads, you need a dedicated remapping table matching 
the position of the source and destination Styles and/or Pads. A separate table 
is needed for the Styles, and one for the Pads. A remapping table can be either 
a tab-separated TXT file, or a comma-separated TXT file.

To see how a table has to be made, you can use a text editor to examine the 
supplied remapping tables (found inside your default Documents folder). It is a 
plain text file (encoded as Unicode UTF-8), with a remapping operation per line. 
Each element of a line can be separated with any number of tabs. Comment lines 
start with a ‘#’ symbol. (To correctly align the elements, we suggest to use a 
non-proportional font).
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In general, this is a remapping table’s structure:

Source Destination Result after conversion

Bnk Pos Bnk Pos

1 1 1 1 Style/Pad 1 in Bank 1 will remain Style/Pad 1 in Bank 1 (its position will 
not change)

1 40 Non remapped. If the “Delete > Song(s) based on non-remapped 
Styles” option is selected, all songs based on this Style will be de-
leted.

1 9 1 29 Style/Pad 9 in Bank 1 will be moved to Style/Pad 29 in Bank 1 (differ-
ent position inside the same bank)

1 37 5 37 Style/Pad 37 in Bank 1 will be moved to Style/Pad 37 in Bank 5 (same 
position in a different bank)

15 4 13 46 Style/Pad 4 in Bank 15 will be moved to Style/Pad 46 in Bank 13 (dif-
ferent position in a different bank)

(Styles not included in the 
matching list)

Non remapped. If the “Delete > Song(s) based on non-included 
Styles” option is selected, all songs based on these Styles will be 
deleted.

In case you are remapping to the Direct banks, please add the path of the Direct 
SET after the Destination columns (including the device label).

Source Destination Result after conversion

Bnk Pos Bnk Pos Path

15 4 37 46 “[label]/foldername1/ 
foldername2/name.set”

Style 4 in Bank 15 will be moved to Direct 
Style 46 in Bank 37, contained in the 
NAME.SET folder.

When converting Style-based SB Entries, MID/KAR-based Entries will be left un-
touched, and included in the destination SongBook as they were before remap-
ping.

Please remap a SongBook only once, or entries will be remapped again to the 
wrong destination.
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Remapping

Back up the current SongBook files

•	 On the instrument, save the SongBook into a new SET folder to keep a safety 
copy.

	Edit the old SongBook on the PC

1	 Use an USB memory device to copy the SET folder containing the SongBook files 
to be converted to your PC.

2	 Run SongBook Editor and choose your Pa-Series instrument as the Target.

3	 Open the SET folder containing the SongBook files to be converted.

4	 Choose the Edit > Song Remap… (Ctrl+R) command to open the Remap dialog.

Style remap 
area

Pad remap 
area

Conversion 
monitoring 
area
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Remap the Styles

Style-based SB Entries include a link to a Style. If the Styles in your instrument 
have changed, you can remap these links.

1	 Select the Style checkbox to remap the links to the Styles.

2	 Click the Browse icon ( ) next to the remapping table name field to open a 
standard file selector, and choose the Style’s remapping table.

The following table shows the ID number corresponding to each bank of Styles. 
Each bank may contain the maximum number of Styles shown in the table.

These data formats can be either the source or target of the conversion:

ID # Type Styles per Bank

Pa4X

1-13 Factory 48

14-23 Favorite 48

24-26 User 48

27-36 Direct Favorite 48

37-39 Direct User 48

40-52 Local 48

Pa1000/Pa700

1-12 Factory 48

13-24 User 48

25-36 Direct User 48

37-48 Local 48

Older data formats can only be the source:

ID # Type Styles per Bank

Pa3X/Pa3XLe/Pa900/Pa600

1-15 Factory 40

18-20 User 40

21-32 Favorite 40

Pa300/HAVIAN 30

1-15 Factory 40

18-20 User 40
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ID # Type Styles per Bank

21-28 Favorite 40

Pa2X/Pa800

1-17 Factory 32

18-20 User 32

21-30 Favorite 32

Pa1X

1-16 Factory 32

18-20 User 32

21-23 Direct FD (B:/DIRECTFD.SET) 32

24-26 Direct HD (C:/DIRECTHD/BANK123.SET) 32

27-29 Direct HD (C:/DIRECTHD/BANK456.SET) 32

30-32 Direct HD (C:/DIRECTHD/BANK789.SET) 32

33 EXB01 64

34 EXB02 64

Pa500/Pa588

1-14 Factory 32

15-16 User 32

3	 Choose whether you want to preserve or delete some entries. This is useful, for 
example, to delete all the entries based on older Styles you no longer want to 
use, or not available in a different instrument.

•	 To preserve all the entries, select the Don’t delete any Song option.

•	 To remove the entries based on Styles you no longer use or have been deleted, 
select the Delete > Song(s) based on non-remapped Styles checkbox. This will 
delete all the entries based on the Styles listed as the Source, but without a 
Destination. (If this checkbox is not selected, the entries will be left untouched.)

In the remapping table, include the Styles you no longer use, or have been de-
leted, in the Source column. The Destination column will be left empty.

•	 To remove a large batch of entries, select the Delete > Song(s) based on non-
included Styles checkbox. This will delete all the entries based on Styles not 
included in the remapping table as the Source. (If this checkbox is not selected, 
the entries will be left untouched.)
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In the remapping table, include all the Styles you want to preserve in the Source 
column, and remap them in the Destination column. Leave out of the Source 
column all the Styles you no longer use.

4	 If you want to create a SongBook with all the deleted entries, to be later re-
viewed, select the Save deleted Song(s) into a SET folder checkbox. This will 
save all the deleted entries into a new SET folder. You can choose the SET folder 
where to save the list; if you type a new name, a new SET folder will be created.

Remap the Pads

Each SB Entry may include links to up to four Pads. If the Pads in your instru-
ment have changed, you can remap these links.

1	 Select the Pad checkbox if you want to remap the links to the Pads.

2	 Click the Browse icon ( ) next to the remapping table name field to open a 
standard file selector, and choose the Pad’s remapping table.

The following table shows the ID number corresponding to each bank of Pads. 
Each bank may contain the maximum number of Pads shown in the table below.

These data formats can be either the source or target of the conversion:

ID # Type Pads per Bank

Pa4X/Pa1000/Pa700

1-20 Factory 48

21-30 User 48

31-40 Local 48

41-50 Direct User 48

Older data formats can only be the source:

ID # Type Pads per Bank

Pa3X/Pa3XLe/Pa900/Pa600

1-20 Factory 32

21-30 User 32

31-38 Local 32

Pa300

1-20 Factory 32
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ID # Type Pads per Bank

21-28 User 32

31-38 Local 32

Pa2X/Pa800/Pa500/Pa588

1-20 Factory 32

21-30 User 32

31-34 Local 32

Pa1X

1-20 Factory 32

21-30 User 32

Remap the entries

•	 Click the OK button to remap the SB Entries.

While the operation goes on, you can see information about the ongoing conver-
sion in the lower area of the dialog.

Edit the Style Settings

After having remapped the entries, linking from older to newer resources, it is 
advisable to also refine the Style Settings. Many Styles (even if they exhibit the 
same name) have been updated during the years, and you may want to adapt the 
old songs to the new settings.
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Saving the SongBook and 
reloading it to the instrument
Once finished editing, save the SongBook and load it back to your instrument.

Saving the edited SongBook

After editing, save the edited SongBook.

•	 Choose the File > Save (Ctrl+S) command to save the file at the original position.

•	 Choose the Save As… (Ctrl+Shift+S) command to save a new file at the desired 
position. When choosing this command, first create a SET folder (for example 
“MySongBook.set”), then save into it.

Quitting SongBook Editor

When finished editing and saving your data, you can quit SongBook Editor.

•	 Choose the File > Quit (Ctrl+Q) command to quit from SongBook Editor.

Disconnecting the storage device from the PC

After having saved all the files, you can disconnect the external USB storage 
device (or the instrument) from the PC.

•	 On the PC, click the Window’s Toolbar > Safe Hardware Removal icon (  ), and 
select the USB storage device (or the instrument’s internal memory or storage 
device) to disconnect it from the PC.
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Loading the edited SongBook on the instrument

To make the edited SongBook active, you must reload it.

1	 Connect the external USB storage device containing the edited SongBook and 
the linked resources (Direct Styles and Pads, MID/KAR, MP3, TXT files) to the in-
strument’s USB HOST port. Leave this device connected to the instrument each 
time you want to use the SongBook.

If you worked on the internal memory of the instrument, or an internal storage 
device, you will reload the SongBook from there.

2	 On the instrument, use the Media > Load operation to load back the edited 
“SONGBOOK” folder from its SET folder. The active SongBook database will be 
updated.
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Frequent operations
There are some frequent operations that can be carried on, and that SongBook 
Editor makes easy to do on a PC.

Changing reference to a bank of Styles

Entire banks of Styles can be freely moved to different ones. This may be useful, 
for example, when moving a User bank to a Favorite or a Custom Factory one (or 
vice versa).

Create a new SET containing the SongBook and the Styles

1	 On the instrument, be sure the SongBook to be edited is already loaded. If not, 
use the Media > Load > [foldername.set] > Songbook operation.

2	 Separately load each of the old banks of Styles into the new banks, by using the 
Media > Load > Style > Bank operation.

3	 Connect an external USB storage device to (one of) the USB HOST port(s).

4	 Use the Media > Save > All operation to save a new SET folder into the exter-
nal USB storage device. This is the SET folder you will work on from SongBook 
Editor.

5	 When done, remove the external USB storage device.

Open the SongBook from the PC

1	 Connect the external USB storage device to an USB port of your PC.

2	 Run SongBook Editor and choose your Pa-Series instrument as the Target.

3	 Open the SET folder you just created. The old SongBook files and the names of 
the Styles will be loaded.

Edit the SongBook from the PC

1	 In the Book panel, click the Resource column header to group all the entries by 
Style bank.
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2	 Select all the SB Entries that were linked to a particular Style bank (for example, 
all the entries linked to all the Styles in the Traditional bank).

3	 Right-click the selected entries and choose the Edit command to open the Edit 
Style Entry dialog for multiple entry editing.

4	 In the Edit Style Entry dialog, you can edit the Bank parameter, by checking the 
corresponding checkbox. Change the old bank to the bank where you loaded 
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your Styles (for example, change it from Traditional to User01). Confirm by click-
ing OK.

5	 Notice how all the selected entries are now referenced to a different bank of 
Styles (for example, from [User01 - 01] to [User01 - 32]).

6	 Save the SongBook and quit SongBook Editor.

7	 Move the external USB storage device, and load the SongBook back to your in-
strument (see page 44).
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Changing reference to individual Styles

Multiple-entry editing allows for assigning a different musical resource to sev-
eral SB Entries at once. This can be useful, for example, to point to a Style that 
you moved to a different position inside your instrument.

Hint: When you have to move several Styles, you could use the Song Remap command as 
a faster alternative.

Create a new SET containing the SongBook with the old Style names

1	 On the instrument, be sure the SongBook to be edited is already loaded. If not, 
use the Media > Load > [foldername.set] > Songbook operation.

2	 Connect an external USB storage device to (one of) the USB HOST port(s).

3	 Use the Media > Save > All operation to save a new SET folder into the exter-
nal USB storage device. This is the SET folder you will work on from SongBook 
Editor. It will contain the old Style names.

4	 When done, remove the external USB storage device.

Open the SongBook from the PC

1	 Connect the external USB storage device to an USB port of your PC.

2	 Run SongBook Editor and choose your Pa-Series instrument as the Target.

3	 Open the SET folder you just created. The old SongBook files and the names of 
the old Styles will be loaded.
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	Prepare the Set Lists

1	 Create a new Set List corresponding to one of the Styles to be later moved in the 
instrument. Name it after the name of the Style. Select the new list to open it in 
the Selected List panel.

2	 In the Book panel, click the Resource column header to group all the entries by 
Style. Find all the entries based on the Style you want to move, and drag them 
onto the Selected List panel. The entries will be added to the new list.

3	 Repeat the above operations for all the Styles you will later move to a new posi-
tion in the instrument.
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4	 When finished editing, save the SongBook, and close it.

5	 Move the external USB storage device, and load the SongBook back to your in-
strument (see page 44).

Create a new SET containing the SongBook with the new Style names

1	 On the instrument, load the edited SongBook by using the Media > Load > [fol-
dername.set] > Songbook operation.

2	 Rearrange the Styles.

3	 Save a new SET folder into the external USB storage device, by using the Media 
> Save > All operation (you may want to overwrite the same SongBook). This is 
the SET folder you will work on from SongBook Editor. It will contain the new 
Style names.

Open the SongBook from the PC

1	 Connect the external USB storage device to an USB port of your PC.

2	 Run SongBook Editor.

3	 Open the SET folder you just created/edited. The SongBook files and the names 
of the new Styles will be loaded.

	Edit the SB Entries

1	 In the Set Lists panel, select one of the new Set Lists where you saved all the 
entries associated to one of the Styles you just moved.

2	 In the Selected List panel, select all the entries of the selected list.
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3	 Right-click the selected entries, and choose the Edit command to open the Edit 
Style Entry dialog for multiple entry editing.

4	 In the Edit Style Entry dialog, check the Bank and Position checkboxes of the 
Style line, choose the bank containing the Style and its new position, then click 
OK to close the dialog.

5	 Notice how all selected entries are now referenced to the correct Style.

6	 Repeat the above operations for all the Style you moved to a new position.

7	 Save the SongBook and load it back to your instrument (see page 44).
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Changing the device and path to your MID/KAR, 
MP3 and Lyrics text files

It is easy to reassign MID/KAR, MP3 or Lyrics text files to the SB Entries. This will 
prove very useful when you switch to a new instrument, and have to move your 
whole archive to the new location. Also, it will be useful when moving your files 
to a different device or folder, for example from the internal memory to an USB 
memory stick, or from the root of a disk to the “Standard MIDI File”, “MP3” or 
“Lyrics” folder.

When editing a single entry, you can edit both the drive unit, the file path and 
the file name. When editing multiple entries, you can only edit the drive unit and 
the file path.

1	 Select the entry(es) to be edited, right-click it (them) and choose the Edit com-
mand.

2	 When the (multiple) entries open, locate the Resource file or Text file line (or 
check the Unit and/or Path checkboxes of the Resources File and/or Text Files 
Path parameters in case of multiple entries).

3	 Choose (or write) the new device or path in the relevant boxes.

You can also click the Browse icon ( ) to browse and locate the new file (or 
folder, in case of multiple selection) in the connected devices.

Drive units, like hard drives and USB storage devices, are represented by their 
label (see table on page 29).

4	 Save the SongBook and load it back to your instrument (see page 44).
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Merging entries from two SongBooks

You can merge entries from different SongBooks, by opening two (or more) ap-
plication sessions, each one with a different SongBook.

Note: When copying an entry to a different SongBook, the entry’s Song Selection Number 
is removed.

Note: When using multiple application instances, choose the same Target on all instances 
(see “Choosing the Target” on page 11).

1	 Run SongBook Editor and open the first SongBook.

2	 Run a second session of SongBook Editor and open the second SongBook.

3	 With the windows of both sessions on-screen, drag&drop entries from one win-
dow to the other one. You can also drag&drop entries between the Book and 
Selected List panels. When moving an entry from a source Selected List to a 
target one, the corresponding entry will be automatically created at the target 
Book panel.

4	 If duplicated entries are found, you are given a choice between keeping the origi-
nal one, overwriting it, or specifying a different name for the new one.

5	 Save the SongBook and load it back to your instrument (see page 44).
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Exporting a list of entries

You can save the content of the Book list or the selected Set List as a text (TXT) 
file. This is the same type of file generated, for example, by the SongBook > Page 
Menu > Export As Text File command on the instrument.

Hint: To print a text file, use a non-proportional font (e.g., Courier) and the landscape page 
layout.

By using the Export command

•	 Choose the File > Export Book… (Ctrl+E) command to save the Book list as a 
text (TXT) file.

•	 Select a Set List in the Set Lists panel, then choose the File > Export List ‘[name 
of the list]’… (Ctrl+Shift+E) to save the selected Set List as a text (TXT) file.

By using the Copy command

1	 Select some entries in the Book or the Selected List panel.

2	 Choose the Edit > Copy (Ctrl+C) command to copy the selected data.

3	 Switch to a text editor or a spreadsheet, and paste the copied data in an open 
document.

By using drag&drop

1	 Select some entries in the Book or the Selected List panel.

2	 Drag the entries to the open document of a text editor or a spreadsheet, and 
drop the selected data at the target position.

Note: Drag&drop might not work with some software. Please refer to the software’s man-
ual for more information.
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Keyboard shortcuts

The following table shows the key combinations that can be used to choose 
menu commands.

Command Shortcut Right-click

File menu

New 

Open… Ctrl+O

Save Ctrl+S

Save As… Ctrl+Shift+S

Import Files… Ctrl+I

Export Book… Ctrl+E

Export Selected List… Ctrl+Shift+E

Preferences…

Quit Ctrl+Q

Edit menu

Cut Ctrl+X √

Copy Ctrl+C √

Paste Ctrl+V √

Delete Del √

Select All Ctrl+A √

Move Up Ctrl+Up √

Move Down Ctrl+Down √

New Entry > Style Ctrl+N √

New Entry > MIDI Ctrl+Shift+N √

New Entry > MP3 Alt+N √

New List Ctrl+L

Filter… Ctrl+F

Song Remap… Ctrl+R

Help menu

SongBook Editor User Guide F1

About…
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Version History

Since its introduction, the SongBook Editor has been subject to improvements 
and addition of new parameters. Please find below the changes since version 1.0.

Version 3.0.0

•	 Now compatible with Pa4X v2.0 (or higher), Pa1000 and Pa700

•	 Dropped support for older instruments

•	 Added support for Guitar Presets

•	 Added support for additional Local resources

•	 Added support for Direct Styles and Pads

•	 Song Selection Number can now be entered by typing the number

•	 Various bug fixes

Version 2.0.0

•	 Now compatible with Pa4X, Pa3XLe and HAVIAN 30

•	 Now compatible with Microsoft Windows 10™

•	 Added the Song Remap feature (for Styles and Pads)

•	 Added the Copy Keyboard Set/STS features

•	 Keyboard Sets/STSs can now be renamed

•	 Direct SET folder support

•	 Redesigned Edit dialogs

Version 1.5.0

•	 Now compatible with Pa900, Pa600 (v1.1) and Pa300

•	 Now compatible with Microsoft Windows 8/8.1™

•	 Added Bank, Style and Voice Preset names in the Book and Selected List panels 
and Edit dialog

•	 SongBook files saved in the target format
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Version 1.4.1

•	 Fixed a bug when exporting lists in TXT format

•	 Fixed a bug that prevented editing Song Numbers

Version 1.4.0

•	 Now compatible with Pa3X v1.1

•	 Now compatible with Microsoft Windows 7™

•	 Added support to Unicode characters

•	 Changed the procedure to select the target instrument

•	 Bank and Location numbers can be separately entered when editing a Style-
based entry

•	 The Key value is correctly imported from a Standard MIDI File associated to a 
new SB Entry; with Pa3X, this is also true for Master Transpose

•	 Fixed a bug that caused major and minor keys to appear inverted in the Edit 
dialog

Version 1.3.0

•	 Now compatible with Pa2X and Pa500/Pa588

•	 Improved compatibility with Pa1X v3.01 and Pa800 v1.51

•	 Now compatible with Microsoft Windows Vista™

•	 Changed New Entry-MIDI shortcut

•	 Fixed a bug that caused major and minor keys to appear inverted in the Main 
screen

Version 1.2.0

•	 Now compatible with Pa800 and Pa1X (v3.0)

•	 Style position and Standard MIDI File/MP3/TXT file path editable

•	 File > Import command added

•	 Edit > New Entry menu revised
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•	 Edited entries shown in red (or any custom color)

•	 Selectable file format (Pa1X or Pa800)

•	 Saved files are no longer compatible with Pa1X prior to v3.0

•	 New shortcuts

Version 1.1.0

•	 Now compatible with Pa1X OS (v2.5.x) 

•	 Song Selection Number reset when copying a Entry from a SongBook to a dif-
ferent one

•	 Harmony Track parameter added 

•	 Resource parameter added
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