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Introduction
Thank you for purchasing a Korg MIDI controller.

To help you get the most out of your new instrument, please read this manual carefully.

What is the KORG KONTROL Editor?
The KORG KONTROL Editor lets you edit the parameters in your Korg MIDI controller, and save the settings on your 
computer.

Caution
 Do not disconnect your Korg MIDI controller while the KORG KONTROL Editor is running.

 Do not use your Korg MIDI controller or the KORG KONTROL Editor while any data is being transmitted.

Operating requirements

Windows
Operating system Microsoft Windows 7 SP1(32bit, 64bit) or later.

Mac
Operating system  OS X 10.8 Mountain Lion or later.

 An internet connection is required for bundled software validation.



KORG KONTROL Editor Owner's Manual3

Installation

Installation for Windows users
Proceed as follows to install the software in Windows.

1. Double-click “Setup_E.msi” to start the installation process.
2. The KORG KONTROL Editor Installer screen will appear. Follow the on-screen instructions to install the software.

Installation for Mac users
Proceed as follows to install the software in Mac.

1. Copy the “KORG KONTROL Editor” folder to the “Applications” folder.
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Quick start

Starting the KORG KONTROL Editor

 In order to use KORG KONTROL Editor with a USB connection, you must download the Korg USB-MIDI Driver from the Korg 
website and install it as described in the accompanying documentation. (http://www.korg.com/)

 If you are using a wireless connection, do not connect the Korg MIDI controller to a computer using a USB cable.

1. Use a USB cable to connect your Korg MIDI controller to your computer.
2. In the “KORG KONTROL Editor” folder, select “KORG KONTROL Editor” to begin.

Mac The “KORG KONTROL Editor” folder is located in the “Applications” folder.

Windows 7 The “KORG KONTROL Editor” folder is located in the taskbar “Start”-“All Programs”-“KORG.”

Windows 8.1 Select the "KORG KONTROL Editor" displayed on the Windows 8 home screen.

Windows 10 The “KORG KONTROL Editor” folder is located in the taskbar “Start”-“All apps”-“KORG.”

3. A list of connected Korg MIDI controllers will be displayed. Please select the controller whose settings you would like 
to edit for. Scene data will be automatically loaded from the selected device.

Editing scene data
Here’s how to edit scene data in the main screen.

1. SCENE buttons will be displayed if the device has more than one scene. Click the scene that you want to edit.
2. In the screen, click the control that you want to edit.
3. The parameters of the selected control are shown in the parameter edit area in the lower right pane. 

This is where you can edit the parameters.

SCENE button GLOBAL button

Controls

Controls

Parameter edit area

Device
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What are scene data and scene sets?
Parameters are assigned to the controls (sliders, knobs, X-Y pad, etc.) of a Korg MIDI controller. These parameter 
assignments are collectively called “scene data.”

Some Korg MIDI controllers have more than one scene; a collection of these scenes is called a “scene set.”

Writing scene data into your Korg MIDI controller
In order for the parameters that you’ve edited in the KORG KONTROL Editor to be reflected in your Korg MIDI controller, 
you’ll need to write the edited scene data into the Korg MIDI controller. Here’s how:

From the “Send” menu, choose “Write Scene Data.” A confirmation dialog box will appear, then click the OK button.

 Do not use your Korg MIDI controller or the KORG KONTROL Editor while any data is being transmitted.
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KORG KONTROL Editor screens and functions
This section provides a brief explanation of the KORG KONTROL Editor’s screens and their functions.

Device select screen
Here you can select the device (Korg MIDI controller) that you want to edit.

From this screen, you can also display a screen that enables you to obtain the bundled software license.

If this is the device whose parameter settings you want to edit, click the OK button.

Show only connected devices
The KORG KONTROL Editor allows you to edit the parameters of a device that is not connected. To do so, un-check the 
“Show only connected devices” check box.

Select this check box if you want to only see the devices that are connected.

 If the preference setting “Specify MIDI ports manually” is on, you won't be able to set the “Show only connected devices” option.

Link to the software bundle download site
You can display a screen that enables you to obtain a license for software that may be bundled with your Korg MIDI 
controller. Use this screen if any software is bundled with the Korg MIDI controller.

 Have a KORG Software Bundle Code ready to obtain the license.

 Full functionality is not guaranteed with all computers that satisfy these system requirements.
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Main screen
The main screen is where you can edit your device’s scene data.

SCENE button GLOBAL button

Controls

CONTROL tab
BROWSE tab Parameter display switch

Parameter edit area

Device

Items on the screen and their function
Device
This area shows an image of the device that you selected in the device select screen.

SCENE button
Click the SCENE button of the scene that you want to edit.

 This button may not be displayed, depending on the selected device.

GLOBAL button
Click the GLOBAL button to access the global data edit screen.

On the global data edit screen, you can set, transfer, save or load data.

 This button may not be displayed, depending on the selected device.

Parameter display switch
This lets you switch the parameters that are shown over each control in the device image.

Parameter edit area
This area enables you to view and edit the parameters of the selected control.

Controls
This area shows the parameters that you selected using the parameter display switch.

If you've selected a parameter that the control does not have, this will indicate “--”.

When you click this, the parameters of the control will appear in the parameter display area.
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Switching the BROWSE / CONTROL tabs
BROWSE tab

This shows the folder hierarchy of your computer’s hard disk.

From the folder and file tree, you can select a scene set file and load it.

CONTROL tab

This lists the controls.

When you click in the control list, the parameters of that control will appear in the parameter edit area.

Basic operation
Here’s the basic procedure for editing in the main screen.

1. If your device has more than one scene, the SCENE buttons are displayed. Select the scene that you want to edit.
2. Click a control in the device image or in the control list of the CONTROL tab.
3. The parameters of the selected control are shown in the parameter edit area. Edit the parameters here.

 For details on each parameter, refer to the owner's manual of your Korg MIDI controller.

Other operations
Cut, Copy, Paste, Clear
You can edit the settings for the SCENE buttons and the controls in the CONTROL tab, by performing “Cut,” “Copy,” “Paste,” 
and “Clear” operations from the “Edit” menu.

Drag and drop
You can exchange the setting for the SCENE buttons and the controls in the CONTROL tab by dragging and dropping.

To copy the settings, drag and drop while holding down the Ctrl key (Mac: Option key).

Undoing the most recent operation
By selecting the “Undo” command from the “Edit” menu you can undo the previous operation.

Redoing an undone operation
By selecting the “Redo” command from the “Edit” menu you can return to the state prior to executing the “Undo” 
command.
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Global data setting screen
Here is where you can edit your device's global data.

Items on the screen and their functions
Parameter setting area
This area enables you to set global parameters.

 For more information on the global parameters, refer to the owner's manual for your Korg MIDI controller.

Receive button
This lets you load global data from the Korg MIDI controller.

Write button
Click this button to write edited global data to the Korg MIDI controller.

Open button
Click this button to load a global data file.

Save button
Click this button to save edited global data as a global data file with a new name.

Close button

Click this button to close the global data setting screen and return to the main screen.
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Preference settings
Choose “Preferences ...” from the “Edit” menu to access the Preferences dialog box.

MIDI ports
Set MIDI ports manually
Turn this on if you want to specify the MIDI ports manually instead of using automatic device detection.

If this setting is on, use the MIDI IN and MIDI OUT fields to specify the ports where your Korg MIDI controller is connected.

MIDI IN
Specify the MIDI IN port where your Korg MIDI controller is connected.

MIDI OUT
Specify the MIDI OUT port where your Korg MIDI controller is connected.

Other
Recieve scene set automatically
If this setting is off, scene data will not be automatically loaded from your Korg MIDI controller when the main screen for 
the device is shown.

Warn before writing
If this setting is off, a warning dialog box will not appear when writing data to your Korg MIDI controller.
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File management
The following data can be transferred between the KORG KONTROL Editor and your Korg MIDI controller.

Displayed device name Type  Content Extension

nanoKEY Scene data
All parameters that can be set on the nanoKEY, such as the 
velocity curve and MIDI channel. 

nanokey_data

nanoPAD

Scene data
All parameters in one nanoPAD scene, such as trigger pads 
and X-Y pad.

nanopad_data

Scene set 
Parameters for four scenes.
(not including global parameters)

nanopad_set

Global data
The nanoPAD’s global parameters, such as the global MIDI 
channel and velocity curve.

nanopad_glob

nanoKONTROL
Scene data

All parameters in one nanoKONTROL scene, such as the 
sliders and buttons.

nktrl_data

Scene set Parameters for four scenes. nktrl_set

nanoKEY2 Scene data
All parameters that can be set on the nanoKEY2, such as the 
velocity curve and MIDI channel.

nanokey2_data

nanoPAD2

Scene data
All parameters in one scene, such as the trigger pad’s MIDI 
channel and note number.

nanopad2_data

Scene set
Parameters for four scenes.
(not including global parameters)

nanopad2_set

Global data
The nanoPAD2’s global parameters, such as the global MIDI 
channel and velocity curve. 

nanopad2_glob

nanoKONTROL2 Scene data
All parameters that can be set on the nanoKONTROL2, such 
as sliders and buttons.

nktrl2_data

microKEY-25 Scene data
All parameters that can be set on the microKEY-25,such as 
the velocity curve and MIDI channel.

microkey25_data

microKEY-37/61 Scene data
All parameters that can be set on the microKEY-37/61, such 
as the velocity curve and MIDI channel.

microkey_data

microKEY2-25 Air Scene data
All parameters that can be set on the microKEY2-25 Air, such 
as the velocity curve and MIDI channel. 

microkey25air_data

microKEY2-37/49/61

microKEY2-37/49/61 Air
Scene data

All parameters that can be set on the microKEY2-37/49/61 or 
microKEY2-37/49/61 Air, such as the velocity curve and MIDI 
channel. 

microkey2_data
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Displayed device name Type  Content Extension

taktile-25/49
TRITON taktile-25/49

Scene data
All parameters that one scene of taktile/TRITON taktile holds 
such as sliders, buttons, trigger pads or touch pads.

taktile_data
tr_taktile_data

Scene set
Parameters for 16 scenes.
 (not including global parameters) 

taktile_set 
tr_taktile_set

Global data
taktile/TRITON taktile global parameters, such as the global 
MIDI channel and velocity curve.

taktile_glob
tr_taktile_glob

nanoKEY Studio

Scene data
All parameters that one scene of nanoKey Studio holds such 
as knobs, trigger pads or touch pads.

nanokey_st_data

Scene set
Parameters for 8 scenes.
 (not including global parameters) 

nanokey_st_set

Global data
nanoKey Studio global parameters, such as the global MIDI 
channel and velocity curve.

nanokey_st_glob

nanoKONTROL Studio

Scene data
All parameters that one scene of nanoKontrol Studio 
holds such as sliders or buttons.

nktrl_st_data

Scene set
Parameters for 5 scenes.

 (not including global parameters) 
nktrl_st_set

Global data
nanoKontrol Studio global parameters, such as the 
global MIDI channel and velocity curve.

nktrl_st_glob
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Menu

File

Select device
Opens the device select screen.

New
Creates a new scene set for the device that is currentry selected.

 For devices that do not feature multiple scenes, use this command to make new scene data.

Open
Loads a scene set file. If you select a file for a device other than the one selected in the main screen, the main screen for 
the device of the selected file will appear.

 For devices that do not feature multiple scenes, use this command to load scene data.

Save
Saves the edited scene set by overwriting the existing scene set file.

 For devices that do not feature multiple scenes, use this command to save scene data to an existing file.

Save As
Saves the edited scene set as a new file with the name you specify.

 For devices that do not feature multiple scenes, use this command to save scene data as a new file.

Load Scene Data
Loads a scene data file into the edited scene.

 This command is unavailable for devices that do not feature multiple scenes.

Save Scene Data
Saves the edited scene as a scene data file.

 This command is unavailable for devices that do not feature multiple scenes.

End
Close the KORG KONTROL Editor.

Edit

Undo
Returns to the state prior to the previous operation.

Redo
Returns to the state prior to executing the Undo command.

Cut
Cuts the selected scene data or control parameter.
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Copy
Copies the selected scene data or control parameter.

Paste
Pastes the cut or copied content to the selected scene data or control parameter.

Clear
Clears the selected scene data or control parameter.

Preferences
Displays the Preferences dialog box.

Send

Load Scene Set
Loads the scene set from your Korg MIDI controller.

Write Scene Set
Writes the edited scene set to your Korg MIDI controller.

Load Scene Data
Loads the scene data of the scene that’s currently selected in the KORG KONTROL Editor from your Korg MIDI controller.

Write Scene Data
Writes the scene data of the scene that’s currently selected in the KORG KONTROL Editor to your Korg MIDI controller.

Help

About
Displays the software version of the KORG KONTROL Editor.
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Troubleshooting

Software won’t start up
• Make sure that your computer meets the operating requirements.

• Check whether other applications might be running. 

If other applications are running, the KORG KONTROL Editor might be unable to start up, or might be unable to transfer data. 

If you’re unable to start up, close all other applications and try again.

• If another USB device is connected, the KORG KONTROL Editor might be unable to start up, or might be unable to transfer 

data. If you're unable to start up or unable to transfer data, disconnect the other USB device from your computer and try 

again.

Can’t transfer data
• Make sure that the Korg MIDI controller has been detected by the connected computer. 

If you are using Windows, go to the Control Panel, open “Hardware and Sounds” → “Device Manager,” and check the “Sound, 

Video, and Game Controllers” tab. 

When using Mac, please check the “MIDI Studio” window. Start “Applications” → “Utilities”→ “Audio MIDI Setup” in order. Select 

“Display MIDI window” from the “Window” menu to open　the “MIDI Studio” window.

• If you are using a USB connection, make sure that the latest Korg USB-MIDI Driver is installed. 

You can download the latest Korg USB-MIDI driver from the Korg website. 

http://www.korg.com/

• If you’re specifying the MIDI ports manually, make sure that the MIDI port settings are correct.

• If you're using a wireless connection, and the computer is far away from the Korg MIDI controller, it might be unable to 

transfer data. Place the Korg MIDI controller closer to your computer.

• If the Korg MIDI controller is using batteries, it might be unable to transfer data if you use a wireless connection when the 

batteries are low. Replace the batteries and try again.

• If you are using a wireless connection, do not connect the Korg MIDI controller to a computer using a USB cable. If the Korg 

MIDI controller is connected to a computer through both a USB and a wireless connection, it will not function properly.

Can’t save global data in a file
• Global data will not be included in a scene set file if you try to save it by selecting “Save” or “Save As...” from the menu. To 

save the global data, use the SAVE button on the global data setting screen　to save it into a global data file.
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